Issue affecting some sites with Let's Encrypt SSL certificates
Incident Report for freistilbox
Resolved
All affected certificates have been renewed and sites are properly and securely reachable.
Posted Mar 04, 2020 - 16:44 UTC
Update
We are now starting to replace certificates.
Posted Mar 04, 2020 - 16:31 UTC
Identified
We have received news from Let's Encrypt that a set of our customers SSL certificates issued by them will be revoked soon due to an issue they've identified with their infrastructure. See https://community.letsencrypt.org/t/revoking-certain-certificates-on-march-4/114864 for background information.

We have already identified all affected certificates on freistilbox and are preparing an emergency renewal for 4.30pm UTC. The certificates of these sites will be unavailable for about 2 minutes during the renewal process.
Posted Mar 04, 2020 - 15:46 UTC