Limited availability
Incident Report for freistilbox
Resolved
This incident has been resolved.
Posted Jan 12, 2017 - 17:41 UTC
Investigating
We have noticed limited availability issues that affect a few customers. We are analysing the situation and are going to update this incident soon.
Posted Jan 12, 2017 - 16:54 UTC