PHP DNS resolving issues
Incident Report for freistilbox
Resolved
The situation has been resolved.

If you notice any problem, please don't hesitate to contact us at support@freistilbox.com!
Posted Mar 22, 2017 - 16:59 UTC
Monitoring
The fix has been rolled out and we're monitoring the situation closely.
Posted Mar 22, 2017 - 15:05 UTC
Identified
A small number of our customers are experiencing issues when PHP needs to resolve DNS entries when accessing external HTTP(S) ressources, eg. via curl, drupal_http_request or file_get_contents.
Currently we only see these errors in the applications error.log with PHP 7.0.

The issues results in error messages like:

* php_network_getaddresses: getaddrinfo failed: No address associated with hostname
* php_network_getaddresses: getaddrinfo failed: Name or service not known
* cURL error 6: Could not resolve host

We are seeing these errors very sporadically and are rolling out a fix at the moment.

If you see these errors please let us know right away at support@freistilbox.com
Posted Mar 22, 2017 - 13:02 UTC